Технические требования к серверу для работы CMS Joomla

  1. Требования к поддерживаемому программному обеспечению
    1. Требования для CMS Joomla 4.x
    2. Требования для CMS Joomla 3.x
  2. Требования к неподдерживаемому программному обеспечению
    1. Требования для CMS Joomla 1.6, 1.7, & 2.5
    2. Требования для CMS Joomla 1.5
    3. Требования для CMS Joomla 1.0
  3. Примечания
  4. Параметры конфигурации WEB-сервера


Все рекомендуемые версии основаны на последней выпущенной версии CMS Joomla каждой серии.

Требования к поддерживаемому программному обеспечению

Требования для CMS Joomla 4.x

Программное обеспечение Рекомендуется Минимум[7] Дополнительная информация
PHP 8.0 7.2.5 https://www.php.net
Поддерживаемые базы данных
MySQL 5.6 + 5.6 https://www.mysql.com
PostgreSQL 11.0 + 11.0 https://www.postgresql.org/
(Поддержка ext/pgsql в PHP была удалена. Теперь используется драйвер PostgreSQL PDO Driver)
Поддерживаемые Web-серверы
Apache[3] 2.4 + 2.4 https://www.apache.org
(with mod_mysql, mod_xml, and mod_zlib)
Nginx 1.18 + 1.10 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 10 + 8 https://www.iis.net

Требования для CMS Joomla 3.x

Программное обеспечение Рекомендуется Минимум[7] Дополнительная информация
PHP[1] 8.0 5.3.10 https://www.php.net
(Magic Quotes GPC, MB String Overload = off)
(Zlib Compression Support, XML Support, INI Parser Support, JSON Support, MB Language = Default)
Поддерживаемые базы данных
MySQL[2] 5.5.3 + 5.1 https://www.mysql.com
(InnoDB support required)
SQL Server 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 https://www.postgresql.org/
Поддерживаемые Web-серверы
Apache[3] 2.4 + 2.0 https://www.apache.org
(with mod_mysql, mod_xml, and mod_zlib)
Nginx 1.8 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net

Список браузеров, поддерживаемых в Joomla 3.x, смотрите на сайте https://docs.joomla.org/Joomla_Browser_Support.

Требования к неподдерживаемому программному обеспечению

Требования для CMS Joomla 1.6, 1.7, & 2.5

Поддержка этой версии CMS Joomla закончилась 31 декабря 2014 года

Программное обеспечение Рекомендуется Минимум Дополнительная информация
PHP 5.6 5.2.4 https://www.php.net
Поддерживаемые базы данных
MySQL 5.0.4 + 5.0.4 https://www.mysql.com
SQL Server[5] 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
Поддерживаемые Web-серверы
Apache[3] 2.2 + 2.0 https://www.apache.org
(with mod_mysql, mod_xml, and mod_zlib)
Nginx 1.1 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net

Требования для CMS Joomla 1.5

Поддержка этой версии CMS Joomla закончилась 31 декабря 2012 года

Программное обеспечение Рекомендуется Минимум[7] Дополнительная информация
PHP 5.3 4.3.10 https://www.php.net
Поддерживаемые базы данных
MySQL 4.1.x + 3.23 https://www.mysql.com
Поддерживаемые Web-серверы
Apache[3] 2.0 + 1.3 https://www.apache.org
(with mod_mysql, mod_xml, and mod_zlib)
Microsoft IIS[6] 7 6 https://www.iis.net

Требования для CMS Joomla 1.0

Поддержка этой версии CMS Joomla закончилась 22 июля 2009 года

Программное обеспечение Рекомендуется Минимум[7] Дополнительная информация
PHP[4] 5.3 4.3.10 https://www.php.net
Поддерживаемые базы данных
MySQL 4.1.x + 3.23 https://www.mysql.com
Поддерживаемые Web-серверы
Apache[3] 2.0 + 1.3 https://www.apache.org
(with mod_mysql, mod_xml, and mod_zlib)
Microsoft IIS[6] 7 6 https://www.iis.net

Примечания

[1] PHP 5.3.1 требуется для версий с 3.0 по 3.2. В версии 3.3 минимальное значение повышается до PHP 5.3.10. CMS Joomla версии 3.5 и более поздние совместимы с PHP 7.

[2] Начиная с CMS Joomla 3.5, добавлена поддержка набора символов MySQL `utf8mb4`, который используется по умолчанию на серверах, которые его поддерживают.

[3] Для того чтобы использовать SEO URL, вам необходимо установить расширение Apache mod_rewrite.

[4] Не используйте PHP 4.3.9, 4.4.2 или 5.0.4. В этих релизах есть известные ошибки, которые будут мешать установке. Zend Optimizer 2.5.10 для PHP 4.4 также имеет серьезные ошибки, и вам следует попросить вашего хостера обновить его до более новой версии. CMS Joomla версии 1.5.15 и более поздние совместимы с PHP 5.3. Обратите внимание, что библиотека OpenID не совместима с PHP 5.3.

[5] Поддержка Microsoft SQL Server была добавлена в релизе 2.5; 1.6 и 1.7 не имеют этой поддержки.

[6] Для Microsoft IIS (в зависимости от вашей установки) вам может понадобиться следующее:

Для получения дальнейшей помощи по использованию Microsoft IIS посетите форум CMS Joomla IIS.

[7] Это минимальная версия, которая гарантированно будет работать, более старые версии могут работать, но не поддерживаются.

Параметры конфигурации WEB-сервера

Если установка производится на локальном компьютере, существует ряд пакетов, которые помогут вам настроить систему быстрее, чем индивидуальная установка:

  • LAMP (Linux) - Большинство дистрибутивов Linux поставляются с предварительно настроенным сервером LAMP.
  • WAMP (Windows) - Для получения дополнительной информации посетите домашнюю страницу WampServer.
  • MAMP (Apple OS) - Для получения дополнительной информации посетите домашнюю страницу MAMP.
  • XAMPP (мультиплатформа) - Не предназначен для живых сайтов. Для получения дополнительной информации посетите домашнюю страницу XAMPP.

Если вам нужны другие варианты, рекомендуется посетить форумы CMS Joomla по установке для получения дополнительной информации или ознакомиться со списком дополнительных технических требований.

Last Updated: 17 August 2021
Перевод с английского официальной документации Joomla:
https://downloads.joomla.org/technical-requirements

Заберите ссылку на статью к себе, чтобы потом легко её найти ;)

Выберите, то, чем пользуетесь чаще всего:

Спасибо за внимание, оставайтесь на связи! Ниже ссылка на форум и обсуждение ; )

Войдите чтобы комментировать

Обсудить эту статью

INFO: Вы отправляете сообщение как 'Гость'