Рейтинг:  0 / 5

Звезда не активнаЗвезда не активнаЗвезда не активнаЗвезда не активнаЗвезда не активна
 

Установка Yii

Установка Yii

composer global require "fxp/composer-asset-plugin:^1.2.0"
composer create-project --prefer-dist yiisoft/yii2-app-basic basic

Первая команда устанавливает composer asset plugin, который позволяет управлять зависимостями пакетов bower и npm через Composer. Эту команду достаточно выполнить один раз. Вторая команда устанавливает последнюю стабильную версию Yii в директорию basic. Если хотите, можете выбрать другое имя директории.

Info: Если команда composer create-project не выполняется нормально, убедитесь, что вы корректно установили composer asset plugin. Вы можете сделать это выполнив composer global show. Вывод должен содержать fxp/composer-asset-plugin. Также можно обратиться к разделу "Troubleshooting" документации Composer. Там описаны другие типичные ошибки. После того, как вы исправили ошибку, запустите composer update в директории basic.

Tip: Если вы хотите установить последнюю нестабильную ревизию Yii, можете использовать следующую команду, в которой присутствует опция stability:

composer create-project --prefer-dist --stability=dev yiisoft/yii2-app-basic basic

Старайтесь не использовать нестабильную версию Yii на рабочих серверах потому как она может внезапно поломать код.

Log in to comment

Discuss this article

INFO: You are posting the message as a 'Guest'